BUG: Indices:data/read/async_search/submit error

Updated to Elasticseach/Kibana 7.7.0, updated Open DIsto Security 1.8 and the users are running into a permission error. Everything looks ok, but they get the following error: “No permissions for indices:data/read/async_search/submit”

Everything worked perfectly prior to the upgrade. I’ve tried the following:

  • Reload the original configuration
  • Give the role all cluster and indices permissions
  • Reload stock permissions with small alterations

The problem is that the indices:data/read/async_search/submit permission doesn’t exist.

Elasticsearch 7.7.0
Centos 7
Kibana 7.7.0

Any input on how to troubleshoot this?

Hi guy, there is a bug not yet corrected https://github.com/opendistro-for-elasticsearch/security-kibana-plugin/issues/274, but you need to rollback to 7.6.1, if you want i posted my configuration on comment of the github bug issues, best regards

Hi Guys, I can’t seem to reproduce the error, tested with odfe 1.8.0 and latest.
What is the user trying to do when this error shows up? Can you share configuration files: internal_users.yml, role_mappings.yml and roles.yml so I could try and reproduce.