Read-only users unable to save search in order to download the csv report

Hi Team,

I have assigned users with read only access as below

cluster permissions: cluster_composite_ops-ro
Index permission: read

Users are able to access the provided indices with readonly permissions however they are unable to save the search and download the csv report

Am I missing to add any of the permission to the role ? pls help

Which version of odfe/OS are you using?

Testing with opensearch 1.0.0, I mapped users to below roles and was able to save searches and download on demand reports:

kibana_user (built-in)
readall (built-in)
additional_role (custom, see below)

    - index_patterns:
        - '*'
        - "indices:monitor/settings/get"
    - cluster:admin/opensearch/reports/menu/download

@Anthony thanks for replying

I am using AWS managed elasticsearch and Kibana. should be [v1.13.2].

I added the roles you suggested in cluster and index permission however the readonly users are still unable to save any search

Error: “Your search was not saved”

Could you please login as read only user and run the below from dev tools and paste the result here:

GET _opendistro/_security/authinfo?pretty

Then login as admin, run the below call:

GET _opendistro/_security/api/roles/<additional/custom_role> (role that was created to use reports)