Unable to install CCR plugin or install via example

Hi I followed the guide here for testing: Announcing the experimental release of Cross-Cluster Replication | Open Distro

This step isn’t working since the link is not found:

RUN /usr/share/elasticsearch/bin/elasticsearch-plugin install -v https://github.com/opendistro-for-elasticsearch/cross-cluster-replication/releases/download/v1.13.0.0-experimental/opendistro-cross-cluster-replication-

I tried to place it with the link below but it doesn’t work.


I tried to install it via Setup for custom Open Distro for Elasticsearch clusters section but it gives those errors below. Tested with both command ( file zip i download from release section of CCR )

bin/elasticsearch-plugin install file://v1.13.0.0-experimental.zip
bin/elasticsearch-plugin install v1.13.0.0-experimental.zip

# Log error

root@sys-test-48-54:/usr/share/elasticsearch# bin/elasticsearch-plugin install file://v1.13.0.0-experimental.zip
-> Installing file://v1.13.0.0-experimental.zip
-> Downloading file://v1.13.0.0-experimental.zip
-> Failed installing file://v1.13.0.0-experimental.zip
-> Rolling back file://v1.13.0.0-experimental.zip
-> Rolled back file://v1.13.0.0-experimental.zip
Exception in thread "main" java.net.UnknownHostException: v1.13.0.0-experimental.zip
	at java.base/java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:220)
	at java.base/java.net.Socket.connect(Socket.java:609)
	at java.base/sun.net.ftp.impl.FtpClient.doConnect(FtpClient.java:961)
	at java.base/sun.net.ftp.impl.FtpClient.tryConnect(FtpClient.java:923)
	at java.base/sun.net.ftp.impl.FtpClient.connect(FtpClient.java:1018)
	at java.base/sun.net.ftp.impl.FtpClient.connect(FtpClient.java:1004)
	at java.base/sun.net.www.protocol.ftp.FtpURLConnection.connect(FtpURLConnection.java:312)
	at java.base/sun.net.www.protocol.ftp.FtpURLConnection.getInputStream(FtpURLConnection.java:418)
	at org.elasticsearch.plugins.InstallPluginCommand.downloadZip(InstallPluginCommand.java:448)
	at org.elasticsearch.plugins.InstallPluginCommand.download(InstallPluginCommand.java:329)
	at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:251)
	at org.elasticsearch.plugins.InstallPluginCommand.execute(InstallPluginCommand.java:224)
	at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
	at org.elasticsearch.cli.MultiCommand.execute(MultiCommand.java:91)
	at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
	at org.elasticsearch.cli.Command.main(Command.java:90)
	at org.elasticsearch.plugins.PluginCli.main(PluginCli.java:47)

Version I used for install plugin

  "name" : "test",
  "cluster_name" : "test-odfe-cluster",
  "cluster_uuid" : "5s3PpRbQSK61riPl3kPiBQ",
  "version" : {
    "number" : "7.10.2",
    "build_flavor" : "oss",
    "build_type" : "deb",
    "build_hash" : "747e1cc71def077253878a59143c1f785afa92b9",
    "build_date" : "2021-01-13T00:42:12.435326Z",
    "build_snapshot" : false,
    "lucene_version" : "8.7.0",
    "minimum_wire_compatibility_version" : "6.8.0",
    "minimum_index_compatibility_version" : "6.0.0-beta1"
  "tagline" : "You Know, for Search"

this won’t work because you need to use an absolute path for file://, see the corresponding docs: Custom URL or file system | Elasticsearch Plugins and Integrations [7.10] | Elastic

furthermore, the ZIP you’re linking to seems to be a complete download of the repository - not the final plugin ZIP. i’m not sure if this has already been published for cross-cluster replication.

you’re right that the link in the Dockerfile is dead, i’ve created a ticket for this:


Thank you for the great explanation <3

@searchymcsearchface : Is there any further support for cross-cluster replication since I haven’t see activity in CCR :frowning: ( i guess you guys are busy with the Open search project )
Edit: nvm. I see the OpenSearch roadmap:

in the 1.1 version it will include CCR.

Yep. CCR had poor timing - getting finished whilst the team had already started on OpenSearch.

1.1.0 of OpenSearch will deliver a lot of these features that just didn’t make it into 1.0.0.


Apologies folks and thanks for reporting.

We have fixed the dead link (while we continue to prepare the OpenSearch release for CCR).

1 Like

Thank you, I will try to learn CCR while waiting for OpenSearch v1.1.0 :smiley:

1 Like