Problem with coordinating node.role

Hello there,
I want to build an Opensearch cluster on docker with:

  • 6 data node
  • 1 master node
  • 1 coordinating node
    data and master node are taking the righ role :
    node.roles: ‘master’ for the master (m)
    node.roles: ‘ingest’, data’ for the data (di)
    But i have a problem with my coordinating node, i set node.roles: ’ ’ but when i run the cluster the coordinating node take dimr parameter ( data, ingest, master, remote-cluster)
    Do you have any idea why coordining node can’t take the righ role?

For coordinating node, I think you have to explicitly set as false for every node roles :

      - node.master=false
      - node.ingest=false

Have you tried this ?
Maybe you can post your docker-compose file / opensearch.yml config.

Another idea, have you tried to make a custom opensearch.yml config file for each node?
You can define their the roles with the parameters :

1 Like

Thanks for your responce, it work well with:

      - node.master=false
      - node.ingest=false