OpenSearch reporting cli tool error

I’m trying to use the OpenSearch reporting cli tool to get reports on my email. Am using an SMTP server to send and report. am getting the following error.

It seems that your password of OpenSearch is not correct, you can check that or escape some characters like ! for the password, like this:


my password is
but it is unable to go to the dashboard.
it just downloads the login page picture and sends mail.

here are the command results

Please help me in this regard.

@mohsin11 Seems that the specified url is not valid, can you add a http port to the url and try again?

my OpenSearch dashboard is running on the 443 port that’s why I have not mentioned the port.

What’s the original url of the short url you specified? If you can download the reporting file successfully by specifying the original url, it’s also ok with the short url.

but it is not reaching to my dashboard. it just just download the login page and sent mail.
even my login credentials are valid.

@gaobinlong please guide me

am getting the same error while using reporting CLI unable to solve it

I’m experiencing the same error did you find a solution?

Same error here, only send a email with the landing page if I don’t specified the authentication type.

Hi, is there any progress on this? Seems still broken🥲 @gaobinlong

Would you mind opening an issue in this github repo: GitHub - opensearch-project/reporting-cli?

Already opened one [BUG] opensearch-reporting-cli tool error · Issue #844 · opensearch-project/reporting · GitHub

1 Like