OpenSearch Dashboards | unable to login | index_not_found_exception no such index

Hello,
We installed OpenSearch(Elastic) on 4 VMs according to documentation(1 coordinating node, 1 master node and 2 data nodes) and after that, we installed and configured OpenSearch Dashboards (Kibana) and when trying to curl or login to it, we are getting following msgs:

[apm@IR-APM-DEV-MN1 config]$ **curl -XGET [http://: -u ‘admin:admin’ --insecure
we are getting following error:
{“statusCode”:401,“error”:“Unauthorized”,“message”:“[index_not_found_exception] no such index [_plugins], with { index="_plugins" & resource.id="_plugins" & resource.type="index_expression" & index_uuid="na" }”}

in OpenSearch Dashboards GUI, we see “Invalid username or password, please try again”

FYI
on OpenSearch installation, we decided to disable security plugin and add following parameter to opensearch.yml file and restarted the cluster
echo “plugins.security.disabled: true” >> /home/apm/opensearch-1.1.0/config/opensearch.yml

Assuming we are ok and not need to configure security plugins/SSL, what missing setting should we have in order to login to OpenSearch Dashboards UI?

Thanks,
Noam

Moving this to the security category.

@noamsh88

What is the purpose of disabling the security plugin? Are you planning to permanently disable security or do you do some testing?

Hi Pablo,
We would like to use opensearch security plugin, but failing execute the securityadmin script, see issue we are facing in following topic:

https://forum.opensearch.org/t/opensearch-tarball-installation-securityadmin-sh-unavailableshardsexception-opendistro-security-0-primary-shard-is-not-active-timeout/7426/3

so mainly we disabled it using plugins.security.disabled: true in order to proceed to OpenSearch Dashboards setup and permanently we would like to enable it , for first installation with testing in this env we can disable