Wrong default credentials for Opensearch Dashboard and Error after Disabling security

Versions - Opensearch 2.11, Opensearch-dashboards - 2.11

Describe the issue:

Hi I’m having a multinode opensearch cluster. All of them were working properly. I tried to install dashboards as well and i left the default config. But then a problem appeared. Im not able to login to the dashboard with the default username and password (admin:admin or kibanaserver:kibanaserver). Tried to find some solution through the forums for changing the password but didn’t work. Then i decided to Disable the security of both dashboard and the opensearch following this link Disabling security - OpenSearch Documentation. But after i try to restart the service it is timing out.

And the error in the logs is: unknown setting [plugins.security.disabled] please check that any required plugins are installed, or check the breaking changes documentation for removed settings.

Can someone please help me to find a solution of this problem

Configuration:

opensearch.yml

######## Start OpenSearch Security Demo Configuration ########

WARNING: revise all the lines below before you go into production

plugins.security.disabled: true
Plugins.security.ssl.transport.pemcert_filepath: esnode.pem
Plugins.security.ssl.transport.pemkey_filepath: esnode-key.pem
Plugins.security.ssl.transport.pemtrustedcas_filepath: root-ca.pem
Plugins.security.ssl.transport.enforce_hostname_verification: false
Plugins.security.ssl.http.enabled: true
Plugins.security.ssl.http.pemcert_filepath: esnode.pem
Plugins.security.ssl.http.pemkey_filepath: esnode-key.pem
Plugins.security.ssl.http.pemtrustedcas_filepath: root-ca.pem
Plugins.security.allow_unsafe_democertificates: true
Plugins.security.allow_default_init_securityindex: true
Plugins.security.authcz.admin_dn:

- CN=kirk,OU=client,O=client,L=test, C=de

Plugins.security.audit.type: internal_opensearch
Plugins.security.enable_snapshot_restore_privilege: true
Plugins.security.check_snapshot_restore_write_privileges: true
Plugins.security.restapi.roles_enabled: [“all_access”, “security_rest_api_access”]
Plugins.security.system_indices.enabled: true
Plugins.security.system_indices.indices: [“.plugins-ml-config”, “.plugins-ml-connector”, “.plugins-ml-model-group”, “.plugins-ml-model”, “.plugins-ml-task”,>
node.max_local_storage_nodes: 3
######## End OpenSearch Security Demo Configuration ########
action.auto_create_index: false


opensearch-dashboards.yml

server.port: 5601
server.host: 0.0.0.0
opensearch.hosts: [http://localhost:9200]

Hey @andrea.petrenko

How did you deploy OpenSearch cluster? Have you tried to change admin’s password using hash.sh tool?

1 Like