Metricbeats-oss and opensearch-rc1 compatibility problem

Hello everybody
About compatibility issues in beats, specifically “metricbeat”, I’ve faced an issue with OpenSearch. The problem has been discussed in these issues:

(Sorry about pastebin’s link. New users can only put 2 links in a post.)

It seems that Mr. Nknize has solved the issue in this commit:

I checked the GitHub repo, this commit is merged in the rc1 version, but I still get the error during the test with the fixed version.
The question is, should I perform a specific configuration when setting thins up in my yml configuration file?

Tested platform:

Also, it’s good to point to OpenSearch’s documentation which discussed “Agents and ingestion tools”. in the “Compatibility Matrices” section has been discussed “Beats oss” and has been mentioned that you can use them “via version setting”. The links point to this issue:
Which is still open.

Hey @lopqto!

So #708 refers to the transport layer not the REST layer. Metricbeat communicates on the REST layer which should be solved by #814 which is expected to be in 1.0 (not 1.0-rc1)