Kibana default pattern randomly resetting

Hello guys !
Sometimes for no reason, my kibana default pattern get lost so I have to select it again.
Do you know how to fix it?
It’s only happening in others customs accounts and they have their personal tenant.


Same thing is happening with me too…

1 Like

Hi @ThibaudF could you provide steps on how to reproduce the issue?

Hello !
It only happens to custom accounts on custom Tenants.

  1. Create an account with his personal tenant and rights on it.
  2. Connects on his account
  3. Create an index pattern
  4. Do your stuff on Kibana and at some point, the default index pattern is gone randomly… Have to select it again…
  5. Sometimes, after connecting again, no more index pattern.

It happens more often when people are connecting on the same account.
I thought it was an error I found in logs about No permission : [indices:admin/template/get]
But it didn’t fix anything.

EDIT : It never happened to the admin account, kibanaserver. So I think it’s about the permissions?
EDIT 2 : It just happened on my admin account too. After several connecting/disconnecting to different accounts.
Thank you.


Hi there,

Still can’t seem to get a repro on this issue.

Tried doing the following:

  1. Created a test_user_role with Index & DocumentType set to * and Action Groups set to UNLIMITED.
  2. Created 2 users test_user1 and test_user2, and created a role mapping between them and test_user_role
  3. Imported some sample data in kibana.
  4. Created multiple index patterns in all user accounts → admin, test_user1, test_user2, and set a default in all of them.
  5. Tried querying through console(in order to generate) load, logging in/out.
    → Didn’t see the default index patterns disappear.

I did search through kibana forums and came across this though →

These, however, don’t seem to offer any concrete solution either. The first link describes something similar to what you are seeing. PS: Not that I think this is browser related - but I am using Chrome in regular mode(not incognito).

Hello !
The problem is still happening.
It’s really random.
I will try to update the version to 0.8.0.

By the way, is it possible to have default index pattern linked to accounts not tenants?
Different users want different default index pattern.

EDIT : I updated to version 0.8.0 and it’s still randomly resetting :hot_face: Kinda lost right now
I will try to update to 0.9.0 and update logstash filebeat too.


We also use multiple tenants and have this issue, that the default index get lost randomly. But we’re on version 0.9.0.

Updated to 0.9.0 and still have the random resets too.
Impossible to find a reason so it’s hard to reproduce…

Hope there will be a fix.

Hi @ThibaudF - If you are still seeing this bug where the Kibana default is not getting saved - can you please file a bug upstream? We will also try to replicate the problem.

Hey @alolitas !
I would be glad to give you such file bug upstream but I have no idea how to make one. :sweat_smile:.

Now the reset is mostly seen every starting of the week.
I restart my server every end of the week (sunday night), and if I check every tenants, some have their default pattern missing, have to select one again.

Tell me how can I help in a better way.
Thank you !

Hi @ThibaudF

While trying to access multiple accounts in the same browser it can happen that the session does not get overwritten. Due to which it makes the default index in Elasticsearch as null and you have to select again.
Try adding this in kibana.yml (kibana configuration file) : opendistro_security.basicauth.header_trumps_session: true