Kibana: Annoying tenant selection pop-up even though multitenancy is disabled

I am deploying ODFE 1.13.2 on Kubernetes using the Helm chart. I have disabled multi-tenancy by setting opendistro_security.multitenancy.enabled: false. However, whenever I open Kibana, it displays a pop-up asking me to select my tenant. Since there are no tenants, none are displayed. But there is a message suggesting I contact my administrator to enable multi-tenancy; which, I believe, confirms it “knows” multi-tenancy has been disabled.

The popup has a “Remember my selection next time” checkbox which I have checked but since the only way to close the dialog is to click “Cancel”, my selection is not saved. This means every time a user logs in, they have to deal with this dialog.

I see an issue (Kibana security plugin - Issue #2) has been opened for this exact problem, however, there has been no response/action.

I also know that OpenSearch 1.0 has gone GA and is where future development work will occur, but my understanding is that we have to migrate our ODFE 1.7.0 clusters to ODFE 1.13.2 before moving to OpenSearch.

Does anyone know how to disable this dialog? Since disabling multi-tenancy is a supported feature, I’m hoping someone has figured out a work-around.

Hello @GSmith

Could you share your kibana.yml file?

Hi Pablo:

Thanks for responding. Here is my kibana.yml file. This was based on the default kibana.yml file I found on the Kibana pod after deploying ODFE 1.13.2 via the Helm chart and allowing the default demo configuration.

As I recall, the only change I made was to set the opendistro_security.multitenancy.enabled to false. I also tried commenting out the opendistro_security.multitenancy.tenants.enable_global and opendistro_security.multitenancy.tenants.enable_private settings and setting them to false as well.

server.name: kibana
server.host: "0"
elasticsearch.hosts: https://my-es-client-service:9200
elasticsearch.ssl.verificationMode: none
elasticsearch.username: kibanaserver
elasticsearch.password: kibanaserver
elasticsearch.requestHeadersWhitelist: ["securitytenant","Authorization"]

opendistro_security.multitenancy.enabled: false                   
opendistro_security.multitenancy.tenants.enable_global: false     
opendistro_security.multitenancy.tenants.enable_private: false    
#opendistro_security.multitenancy.tenants.preferred: ["Private", "Global"]  
opendistro_security.multitenancy.tenants.preferred: ["Global"]   
opendistro_security.readonly_mode.roles: ["kibana_read_only"]

# Use this setting if you are running kibana without https
opendistro_security.cookie.secure: false

newsfeed.enabled: false
telemetry.optIn: false
telemetry.enabled: false
security.showInsecureClusterWarning: false
# To configure a WMS map server for use with Kibana, see:
# https://opendistro.github.io/for-elasticsearch-docs/docs/kibana/maptiles/
map.includeElasticMapsService: false

I am also facing the same issue after disabling tenancy in opendistro 1.13.2.0. how can I remove or disable that popup?

1 Like