Errors when installing plugins in OpenSearch Dashboards


We’ve recently built our own version of OpenSearch Dashboards 1.0.0 in Docker with a few small UI changes. We’re now trying to install the securityDashboards plugin, but encountering a few issues. We found a forum post that previously discussed this and we think it may be the same issue and fixed in 1.1.0 (we’re yet to upgrade, though):

We’ve tried to install via RUN /usr/share/opensearch-dashboards/bin/opensearch-dashboards-plugin --allow-root install securityDashboards and get the following logs:

Attempting to transfer from securityDashboards
Attempting to transfer from
Plugin installation was unsuccessful due to error "No valid url specified."

We originally wondered if this only exists in our build, so we tried building an image FROM opensearchproject/opensearch-dashboards:1.0.0, which produces the same error (as mentioned before, it’s fixed in 1.1.0). We tried installing from a URL ( and the artifacts repo gives the same error, as rightly should.
We then tried wgetting the tagged 1.0.0 release on GitHub and the on the install step this gives the following error: Plugin installation was unsuccessful due to error "No opensearch-dashboards plugins found in archive"

Here’s the Dockerfile where you can reproduce the issue (GitHub download commented out):

FROM opensearchproject/opensearch-dashboards:1.0.0

USER root
RUN /usr/share/opensearch-dashboards/bin/opensearch-dashboards-plugin --allow-root remove securityDashboards
#RUN yum install -y wget &&\
#    wget && \
#    /usr/share/opensearch-dashboards/bin/opensearch-dashboards-plugin --allow-root install file:///usr/share/opensearch-dashboards/
RUN /usr/share/opensearch-dashboards/bin/opensearch-dashboards-plugin --allow-root install securityDashboards
USER 1000

Based on the previous ticket that was raised that I mentioned, one user was able to download from the artifacts repo and install using that. I was wondering if someone could help me with providing the right link to the artifact repo for securityDashboards v1.0.0.0?

Cheers :slight_smile:

FYI - 1.1.0 isn’t out yet :slight_smile: Are you talking about 1.0.1?

With regards to standalone, compiled plugin artifacts, currently those aren’t publish, but I think the team would be open to it.

Would you mind opening an issue in opensearch-build?

Ah, I figured 1.1.0 would have been based on the roadmap, on the post that I linked you said it would be fixed is all :slight_smile: