Unauthorized error, while running OpenSearch a docker container

Hello guys,
I got an error message while running the curl https://localhost:9200 -ku 'admin:admin'. I guess, that the error message received indicates that the server could not be verified and a secure connection could not be established.

In order to solve this, I already tried to skip SSL certificate validation and avoid the “unauthorized” error, using commands:

curl https://localhost:9200 -k -u ‘admin:admin’

curl -k https://localhost:9200/_nodes/plugins?pretty

And use the --insecure flag with the curl command to disable certificate verification.

But none of them helped me, to verify that I have successfully configured OpenSearch with security features.

Any help would be appreciated!

P.S. Before that, I went through these steps on a home computer, which is now under repair due to congestion. Now I’m trying to download through a working laptop, but I get this error.

the ‘-k’ option in the curl command tells curl to skip SSL certificate validation.
Check if the opensearch image is working correctly?

Orbulon, thanks for your comment, the openseach is appeared in the image section in docker. See the screenshots below, please.

Any suggestions?

You have the “Run” button in the screenshot
Does that mean you tried it without the image running? If yes, then run and look at the logs, in “in use”