Timelion fails in kibana 1.12

We upgraded to kibana 1.12 and timelion scripts stopped working. Any known problems ?
We get syntaxerror on scripts.

the default .es() shows a curve for some index that may be default …
,index=uninett)’ gives a line along the xaxis. Discover shows data in the index so the curve is wrong.

The visualization development pane does not show the script when an error message is given - see enclosed image. How can I expand the pane pane to see the code ?

The code :
.es(q=event_type:gap,index=dragonlab,metric=‘sum:tloss’,kibana=true,timefield=timestamp_ms).divide(1000).divide(60).bars().label(‘Sum down(min)’))

The error message :
Timelion request error: undefined SyntaxError: {“type”:“incompleteFunction”,“function”:“es”,“location”:{“min”:0,“max”:3},“text”:“.es”}

I ran into this recently with some older dashboards, I think it came down to quoting on some of the elements in the query that ultimately fixed it for me. I remember having to refer to the timelion docs for the language to figure it out.

Thanks, I have quoted q= without luck. But the statement above runs in the separate timelion workbench. So might be that the integrated timelion in the dashboard is different ?The error messages mentions ‘location: min:0, max:3’ but I have no min and max in my statement …

I do not see errors with this:
.es(q="event_type:gap",index=dragonlab,metric=sum:tloss,kibana=true,timefield=timestamp_ms).divide(1000).divide(60).bars().label("Sum down(min)")

Hope that helps.

1 Like

Thanks ! - That solved the problem. Looks like the new Timelion builtin parser only accepts double quotes.
A slight hint to the parser folks could be to investigate the possibility of producing a more to the point error message :wink: