SQL Workbench not working when using Kerberos authentication

SQL Workbench not working when using Kerberos authentication. It returns “no response”. After monitoring network traffic, I noticed it was issuing a POST request to https://kibanaserver:5601/api/sql_console/query with request body as {“query”:“select * from testindex”}. It returns internal server error.

I am using the below configuation to enable kerberos on Kibana.

opendistro_security.auth.type: “kerberos”

Note that SQL Workbench works fine when setting opendistro_security.auth.type: “basicauth” and authenticate through LDAP.


try to reproduce this, will followup here, thanks

@anirudha I think Kibana does not support kerberos but there is not clear statement about it in the Documentation. I didnt find its implementation in the source code.

Hi @asfoorial the endpoint should be the elasticsearch host rather than kibana. This endpoint is only for kibana plugin use to send request to ES. If you send requests to the kibana host something like https://kibanahost/api/sql_console/query would not be sent to es backend directly because of security.