Rsyslog config to use demo certificates?


I started using elasticsearch and kibana, configured rsyslog to send its logs directly to elasticsearch. That worked.

Now I installed elasticsearch and kibana with opendistro. Now I have to connect via https. While that works with kibana, rsyslog seems to have some issues with that, which might be coming from my lack of understanding certificates.

I saw that in /etc/elasticsearch/ there are some demo certificates.
In rsyslog I tried setting usehttps=“on” but I also have to specify a ca certificate, something called mycert and a private key?

Which files from the demo ssl files do I need to specify?
Thanks and sorry for a potentially stupid question :slight_smile:

1 Like

@Arp Did you get this resolved? I haven’t used rsyslog, but usually you need to specify the ca cert which would usually be located at /usr/share/elasticsearch/config/root-ca.pem.
Hope this helps