OpenSearch Dashboards - Disable Security Plugin Issue

Hello OpenSearch community,

I’m trying to disable OpenSearch Security plugin for both OpenSearch and OpenSearch-Dashboards, but having trouble following the documentation.
I was able to successfully disable the security plugin for OpenSearch, but having trouble with OpenSearch-Dashboards.

For OpenSearch-Dashboards, there are two options to disable the security plugin:

  1. Add docker environment variable DISABLE_SECURITY_DASHBOARDS_PLUGIN=true
  2. Remove the security plugin manually, by running → sudo bin/opensearch-dashboards-plugin remove

I’ve already tried the first option, by adding DISABLE_SECURITY_DASHBOARDS_PLUGIN to my values.yaml under “extraEnvs” (btw, I’m using helm and kubernetes).
This method didn’t work, as I kept getting redirected to the login page when I tried to access OpenSearch-Dashboards from my browser.

The second option was easy to follow through, except, it asked me to restart my opensearch-dashboards instance and I’m not sure how that is done,
as I couldn’t find any documentation on how to stop/start my OpenSearch-Dashboards instance (I also tried exploring inside my VM file directory
and the closest thing I found was /bin/opensearch-dashboards script that only supports “serve” command based on the help guide).

In kubernetes, you can delete a pod, but that gets rid of any changes you make and essentially spins up a new pod.

For reference:
Disable security - OpenSearch documentation.

Any help is appreciated,
Thank you,