Opensearch Dashboards default route not working?

Hi there!

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):
I’m using the last version : the 2.13.0

Describe the issue:
I want to configure a kind of landing page. After the login, I want the users redirected into a dashboard.

In the Dashboards Management > Advanced settings, I change the default route from /app/home to /app/dashboards?security_tenant=global/view/ID_OF_THE_DASHBOARD

I have two different behaviour :

  • Right after the login, I’m not redirected to the dashboard but I arrived on /app/home instead of /app/dashboards
  • If I remove /app/home frome the URL and click on “Enter”, I arrive on the dashboard

What configuration can I do to make sure my users all land on a specific dashboard, without come first by “/app/home”?

Best regards,

I have the same problem in 2.13

what’s the default tenant for current user, and which tenant you are making changes with? The different tenants will have different settings.

e.g. If the default tenant is private, after login, OSD will read the default route from private tenant settings instead of global tenant settings.
If you make changes within global tenant, it will not read that value after login in.

Thanks @hailong ! It seems it was the solution after all!

After defining the default tenant as global in Security > Tenants, it works now as expected!