OpenSearch Benchmark not able to run

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):

Version: 2.11.1

Describe the issue:

Opensearch is running in a Docker container. It can be reached at port 9200 and the dashboard is also online.

I am able to get the status of the cluster with: curl -XGET http://localhost:9200/_cluster/health?pretty.

However, I am not able to get OpenSearch Benchmark to run. When I try, I get this error:

[ERROR] Cannot execute-test. Error in worker_coordinator (OpenSearch REST API layer is not available.)

[INFO] FAILURE (took 9736 seconds)

The command used to run OpenSearch Dashboard is:

opensearch-benchmark execute-test --target-hosts http://x.x.x.x:9200 --pipeline benchmark-only --workload http_logs --test-mode --distribution-version 2.11.1

I’m not sure why it would be complaining that the API is not available if both the curl commands and the dashboard are working.

@tgeek77 Did you disable or remove the security plugin in OpenSearch?

No, this is a vanilla installation. Nothing was removed.

However, I think I found that problem. I think the benchmark is having problems with our proxy.

@tgeek77 I’ve tried your command on the docker Opensearch node with no security plugin installed and all worked.

However, I didn’t have any proxy in the front.
Have you tried this proxy configuration for opensearch-benchmark?

Not yet. That’s going to be the next things I’m going to try.