Opensearch: ARCInvalidSignatureException (403)

Opensearch version : 2.9

I recently upgraded OS version to 2.9 and noticed this error while trying to create dashboards from my visualization.
“aws.auth.client.error.ARCInvalidSignatureException: Invalid signature, does not match”
Every other feature after the migration works just fine.
We use AWS cognito and I have revisited all the roles. I had done the same set up(Cognito included) with OS version 2.7 and it worked perfectly fine.

In addition to this, my Opensearch console just stops working after this error and requires me to re log-in.

Even trying to load Opensearch provided sample dashboard([Flights] Global Flight Dashboard) is throwing an error.

@Dijenliu Could you share your config.yml, opensearch.yml and opensearch_dashboards.yml files?

thanks @pablo for responding to this. I have meanwhile solved the issue.
Disabling the plugin augmentation did the work in my case.

We’re also experiencing this after upgrading to OS 2.9. This is a pretty plain vanilla hosted setup in AWS. Disabling plugin augmentation worked for us as well