Metricbeat cannot start in Open Distro

Exiting: data path already locked by another beat. Please make sure that multiple beats are not sharing the same data path (

This is the error msg when I try to load metricbeat.
So, when I run “metricbeat setup” it is not loading the dashboards. So when I check with metricbeat -e it shows the msg above and I’m very sure that there is no other beat installed!
Any solution for this, any similar or same issue like this !?

Another error that I’m dealing with is:
ERROR [publisher_pipeline_output] pipeline/output.go:154 Failed to connect to backoff(elasticsearch(http://X.X.X.X:9200)): Connection marked as failed because the onConnect callback failed: Metricbeat requires the default distribution of Elasticsearch. Please update to the default distribution of Elasticsearch for full access to all free features, or switch to the OSS distribution of Metricbeat.

For more info the versions are the same:

I think you need to use OSS version of metricbeat.

1 Like

Yes, exactly! But as I’ve posted that the version numbers was the same but again after check and recheck now it works!
Thank you!