Logstash input with logstash-input-opensearch plugins fail without ssl

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): logstash 7.17.6
Describe the issue:
Hello, I want to retrieve OpenSearch data using Logstash 7.17.6. To achieve this, I’m using the Logstash plugin ‘logstash-input-opensearch’ and creating a Logstash pipeline with the following input configuration:


input {
  opensearch {
    hosts =>  ["https://HOST:PORT"]
    user  =>  "USERNAME"
    password  =>  "PASSWORD"
    index =>  "my_index"
    query =>  '{ "query": { "match_all": {}} }'

When I run it, the result fails with the error logs ClientProtocolException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find a valid certification path to the requested target.

My question is, how can I use the opensearch input without SSL validation? I have tried adding ssl => false or ssl_certificate_verification => false, but it doesn’t work.

Relevant Logs or Screenshots:

Because the specified host uses https, so ssl must be true, but cert verification can be false, like this:

ssl  => true
verify => false