Email type is not showing up in Alerting -> destinations


We recently upgraded from ElasticSearch v7.10 to OpenSearch v1.2.0. We are trying to configure alerts but the email type is missing in destinations. We tried with the admin account still no luck. Official v1.2 documentation ( Monitors - OpenSearch documentation ) has email as one of the types. Any special permissions are needed to enable the email connector?


Hi @Sravanthi - any chance you could post a screenshot of what you’re seeing? I see Email in this drop-down here:


Hi @nateynate, here you go

this is restricted by aws opensearch service.

1 Like

Is there any way to enable it or is it restricted permanently from aws opensearch?

it disabled because aws opensearch does not want to connect to smtp server in a with no-auth, basic-auth, smtp protocol does not support IAM creds… so you are left with SNS. they said they might support SES in future.

1 Like

okay. thanks for the info

Sorry about that - I should have disambiguated between the open source project and the managed service. My bad there. :slight_smile: