Docoment level Security not working

Hi opendistro community , lately i’ve tried implementing the document level security feature in my dashboards but i’m stuck , i’m using the default admin user, when i configure dls it gives me this error

[data] [elasticsearch] [version_conflict_engine_exception]: [config:7.10.2]: version conflict, document already exists (current version [4])

this is my dls query :

“bool”: {
“must”: { “match”: { “host.hostname”: “******”}}

i’ve posted another topic about this(Document Level Security version conflict error) but nothing yet , i’m really stuck and i’ve tried a lot of things and nothing worked , any help would be appreciated guys
thanks in advance.
PS: i’m using the latest version of OD and ELK 7.10.2.

@HeiDri The latest version supported by ODFE is 7.10.0, please refer to this link
Therefore the plugin (assuming 1.12.0 / 7.10.0) will not be able to work with 7.10.2. Hope this answers your question

@Anthony i’ve rebuilt the plugin to make it work on ELK 7.10.2

@HeiDri I don’t think you will be able to get the answer you are looking for as you now made a custom plugin, but the error you are getting is exactly what mismatched version of plugin would complain about.

@Anthony , thanks for the response , i found my error , it was that when setting up DLS for all indices (“*” ), this also affects the Kibana index , as the Kibana index most probably does not have the attribute i’m using in DLS , Kibana cannot read/write anything from this index. So, the login fails ,So, the solution would be using a more specific index pattern for the DLS rule.