Dashboard Error While Filtering Data

OpenSearch Dashboards:

Hi guys! I don’t know if it’s the right group to start this conversation. But I’m having troubles while trying to set my OpenSearch Dashboards (in my Wazuh) to filter the “count” data as “desc” automatically. Now I’m doing everything manually when I want to generate a report. Does anybody knows how to solve it?


Obs: This image came from a “OpenSearch Dashboards” Table.

You may need to reverse the visualizations before saving

But therein lies the problem! I already put it in descending order before saving. But on the main Dashboard, the error remains ;-;

Can you please let me know the version of Opensearches and Visualization you are using, as I have no problem using table testing

Now, I’m using the 2.6.0 version.

Table has an Order during production


Thanks for the answer. But it’s strange, because I don’t have this option. Let me show you how it appears to me:


Obs: The size that I’m using, it’s just a test to catch all the results instead of only 5, for example. And if you go to “Advanced” section, you’ll only find a Json input and Exclude/Include field.

Do you think that there’s a way to enable the “Order” option?

Dude, I just don’t know what to do anymore. Even changing the JSON file I did, but still had no success.

Hey, I found the solution!

The problem: I was using the “Significant Terms” aggregation, instead of “Terms”. When I changed the Aggregation field, the “Order” option became visible. Thanks for the help and the time spent!