AWS OpenSearch Dashboards v1.2 - Error fetching hot indices: Invalid index name [_hot], must not start with '_'

Hello, I’ve updated from AWS OpenSearch 1.1 to the latest 1.2. And now I’ve got an issue when trying to list my hot and warm indices.
What should I do to fix it ? Any ideas?

OpenSearch Dashboards → Index Management → Hot/Warm indices.

Full error:
Error fetching warm indices. {"error":{"root_cause":[{"type":"invalid_index_name_exception","reason":"Invalid index name [_warm], must not start with '_'.","index":"_warm","index_uuid":"_na_"}],"type":"invalid_index_name_exception","reason":"Invalid index name [_warm], must not start with '_'.","index":"_warm","index_uuid":"_na_"},"status":400}

Actually, I don’t have any indices starting with ‘_’. Also, it was working on my previous version - OpenSearch Dashboards v1.1.

It is clear we can not use index names starting with ‘_’.
But I guess in 1.1 Opensearch forget that check and in 1.2 they added backup again somehow xD

You might have to change the prefix for hot indices

1 Like

Thanks for your reply)

I believe that in my specific case AWS support team should fix this issue from their side, because I’ve no idea what can I do from my side.

i have the same issue,
tried to downgrade the version but its still the same.

do you have any solution for this ?

Hello, I haven’t.

But I created a GitHub issue and waiting for support from the OpenSearch community.

That is a known issue on the managed service - please cut a support ticket and they should be able to help resolve it.

1 Like