About "Tenant indices migration failed" error in kibana

I use the 0.8.0, the same issue comes back. I checked the file /usr/share/kibana/plugins/opendistro_security/lib/multitenancy/migrate_tenants.js, it is correct.
can someone help check it?

the default install has no issue, my issue is due to the custom .kibana index, which account don’t have access.

I’m having this same problem with 0.7.0.1

Did you find a solution?

Hi,

You can fix it by disabling multitenancy in default kibana configuration. Change this line opendistro_security.multitenancy.enabled: true
to
opendistro_security.multitenancy.enabled: false

Path for default config file in docker is /usr/share/kibana/config/kibana.yml.

I needed multi tenancy enabled for my use case.
I was able to resolve by going to my Elasticsearch Directory, and going to
/elasticsearch/plugins/opendistro_security/securityconfig/config.yml

and un-commenting
kibana:
# Kibana multitenancy -
# see
# To make this work you need to install
multitenancy_enabled: true
server_username: admin
index: ‘.kibana’
do_not_fail_on_forbidden: false

I was also getting this error. I am using docker version for elasticsearch and kibana. I believe it was because the elasticsearch nodes were not running.

I installed the version of opendistroforelasticsearch-kibana 1.0.0 and saw this error.

The next line is not commented out.
import { KibanaMigrator} from “…/…/…/…/src/legacy/server/saved_objects/migrations/kibana”;

I would be grateful for the help.

1 Like

Hello i have the same problem here, the line is uncommented, could you fix it eventually?

open-distro kibana v1.2
same problem here

Same issue here and same error reported by @misiakj:

[error][migration] Authorization Exception :: {"path":"/_opendistro/_security/tenantinfo","query":{},"statusCode":403,"response":""}
    at respond (C:\elk\kibana-7.2.0-windows-x86_64\node_modules\elasticsearch\src\lib\transport.js:315:15)
    at checkRespForFailure (C:\elk\kibana-7.2.0-windows-x86_64\node_modules\elasticsearch\src\lib\transport.js:274:7)
    at HttpConnector.<anonymous> (C:\elk\kibana-7.2.0-windows-x86_64\node_modules\elasticsearch\src\lib\connectors\http.js:166:7)
    at IncomingMessage.wrapper (C:\elk\kibana-7.2.0-windows-x86_64\node_modules\elasticsearch\node_modules\lodash\lodash.js:4935:19)
    at IncomingMessage.emit (events.js:194:15)
    at endReadableNT (_stream_readable.js:1103:12)
    at process._tickCallback (internal/process/next_tick.js:63:19)

Uncommenting the multitenancy configuration part in /elasticsearch/plugins/opendistro_security/securityconfig/config.yml as suggested above by @misiakj himself didn’t work in my case.

I have opened an issue about this.

Issue is still observed with security plugin 1.1.0.0 and Kibana 7.1.1
Kindly let us know how to resolve this?

I resolved this issue by deleting the offending index.

Can you please explain more? I have the same problem.

Hello everyone,
Can you please share your solution? I cannot disable multitenancy. Here is my issue:

me, too!!
this problem is zombie form hell!!!

:slight_smile: I added a node and tried to disable multitenancy, it seems OK now. But some problems when I login with other users. I really need multitenancy feature.

Encountered the same issue with SearchGuard, while upgrading from 6.6.2-18.5 to 6.6.2-19.0

An ugly hack though, but deleting all tenant indices & templates i.e. indices like kibana__<version_number> & then restarting kibana solved the issue as it didn’t need to do the migration in this way. Make sure to backup these using a tool like elasticdump. The tenant indices then could be restored if needed.

Hy, i have de some ploblemkibana error

I need help, pleasy. .

I have the same issue every time I restart Opendistro. What I do is:

  • Restart Kibana
  • Read Kibana logs and find a message that looks like: {"type":"log","@timestamp":"YYYY-MM-DDTHH:mm:ssZ","tags":["warning","migrations"],"pid":1,"message":"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_-xxxxxxxxx_somename_yyyyy and restarting Kibana."}
  • Execute in Elasticsearch the following command (this will delete that index): curl -k -XDELETE "https://admin:PASSWORD@localhost:9200/.kibana_-xxxxxxxxx_somename_yyyyy"
  • Restart Kibana

You will delete that .kibana index, but I didn’t find a better solution.

At ES/Kibana 1.4.0, It is weird but I solved this issue.
I have same issue even though delete all “.kibana_*” indices.
I uncommented these lines at kibana.yml:
#elasticsearch.requestHeadersWhitelist: [“securitytenant”,“Authorization”]
#opendistro_security.multitenancy.enabled: true
#opendistro_security.multitenancy.tenants.enable_global: true
#opendistro_security.multitenancy.tenants.enable_private: true
#opendistro_security.multitenancy.tenants.preferred: [“Private”, “Global”]
#opendistro_security.multitenancy.enable_filter: false

and I can access security config with internal users only…