1.10.1 Alerting Gmail Auth Issue

Hello all,

Trying to setup a destination using the new email destination functionality. I’ve setup the sender, using TLS on port 587 and smtp.gmail.com as the server. I’ve also confirmed I’ve set up the username and password correctly in the elasticearch keystore, but I keep getting this error in the elasticsearch logs when I send a test message through a trigger:

Message published for action name: Test Email, messageid: 530-5.7.0 Authentication Required. Learn more at
530 5.7.0  https://support.google.com/mail/?p=WantAuthError 

Has anyone else experienced this?

Hi @lmurph,

A couple things that may help you out:

  1. If you’ve entered the email and password settings into the keystore while Elasticsearch is still running, you’ll want to reload the settings so your changes are reflected:
curl -X POST "localhost:9200/_nodes/reload_secure_settings?pretty" -H 'Content-Type: application/json' -d'
  "secure_settings_password": "1234" 

Note: The secure_settings_password part is only required if your keystore is password protected.

  1. From my experience with using a gmail email account, if TLS and port 587 doesn’t work, try SSL and port 465

Hello @qreshi,

Running the curl request did it, thank you! This might be something worth putting in the docs?

Glad to hear it @lmurph.

The docs for this feature were being drafted and are now available. This information can be found there as well.

Sorry @qreshi , why when I make the curl request, the response from elasticsearch is empty?