Use the debugger on Opensearch dashboard

Am I the only one having issues with the debugger ? It’s inconsistent and doesn’t hit the breakpoint exactly where it’s defined.
It looks like it’s not following the typescript code accurately.
I tried removing the ‘#cheap-source-map’ after watching this video (really useful by the way) :

(4:34 to see the part where they talk about cheap-source-map).

But still no way to fix this. I am using mac OS and webstorm by the way.

For now I am using the chrome debugger since it’s working fine, but I think this problem comes from the base path.

@kavilla @mihirsoni @ahoppity @seanneumann
I pinged you because I found you from github :wink:

Since you’re regular contributors to opensearch dashboard, I was wondering if you had the correct launch.json configuration to make opensearch dashboard debuggable in VScode. (launch.json is a file specific to vs code that defines how to run run the debugger)

Right now, this is my launch.json

            "type": "pwa-chrome",
            "name": "osd",
            "request": "launch",
            "url": "http://localhost:5603/MY_BASE_PATH",
            "webRoot": "${workspaceFolder}",
            "remoteRoot": "${workspaceFolder}",
            "sourceMaps": true,
            "trace": true,

What I am currently able to do is :

  • set breakpoint in chrome directly => easy to do, but the debugging environment is not ideal, compared to vscode
  • type debugger; and debug inside vscode => it’s a pain since I have to remove the debugger; after I am done.

What doesn’t work is setting up breakpoints in VScode.
I tried run node in nolazy, didn’t work.