UPDATE Version 1 to version 2 do opensearch, dashboard

guys, i need to update opensearch and dashboard from version 1.2 to 2.3.
I use opensearch with docker.
I just tried to change the image from 1.2.0 to 2.3.0 and it didn’t work. it lost all storage that was on the node i upgraded.
look how it appears on the dashboard

Hi @angelogabeira,
I have not done such an upgrade myself, but I found another post from a user who also had to upgrade to version 2.X.

I hope the update process works for you if you first update to version 1.3.5 and then make the switch to version 2.3.
What I can tell you for sure, however, is that OpenSearch Dashboards unfortunately does not like mixed-use clusters. OpenSearch Dashboards didn’t even started with my mixed cluster with a 2.2.0 node and a 2.3.0 node that are only a minor version apart. Maybe this is the Reason why that one node showed up that strange.
In case this didn’t help you we can both try this in our Test Lab so we can share our experiance and work out a Solution. :slight_smile:

I would be extremely grateful if you could help me more and do this test in your lab.
the most difficult problem is to take advantage of the content of the data nodes.

Hi @angelogabeira,
i think i have good and bad news.
The good one is that i just successfully upgraded from OpenSearch Docker Version 1.2.0 to 2.3.0.
The Upgrade Process worked fine without any Data loss. I index some Logs from my Test Server and every Single log was still there without any failure.

The bad News are that you have to update to the next Minor Release till you hit the Version 2.3.0.
Here you can skip the Bug Fix releases like 1.3.1 - 1.3.5 and 2.2.1.

I tried to mimic your Environment as good as i can. I set up 5 Docker Container with different roles.
I have to inform you that if you update to the Version 2.3.0 you will get a deprecation warning for the Option “cluster.initial_master_nodes”. This one was renamed to “cluster.initial_cluster_manager_nodes” cause of the Political Correctness. The Syntax for this is the same so you just have to rename it.

1 Like