"Unauthorized" error when completing the final step in the Debian setup

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):

  • 2.9 OpenSearch
  • Azure VM
  • Ubuntu 20.04

Describe the issue:
I am looking to create a remote instance of OpenSearch on an Azure VM (Ubuntu 20.04). I used the Debian documentation closely to build the OpenSearch server on the VM, no problem.

When trying to test the connection remotely, I continue to hit an “Unauthorized” error. I’m not sure what the issue is, but after several hours of research, still not successful.

Any guidance would be appreciated. :slight_smile:


Relevant Logs or Screenshots:

@jacoma How exactly do you test this connection?

Thanks for the reply.

I test the connection using this command in the documentation here.

curl https://your.host.address:9200 -u admin:yournewpassword -k

Further context, I test it on my local machine. I always tried it on the remote server (Azure VM) itself. Both result in “unauthorized”.

@jacoma Please backup your config with securityadmin.sh and share config.yml, roles.yml and roles_mapping.yml files.

The securityadmin.sh script uses admin certificates and certificate authentication, it will bypass all the security configurations and allow you to download the configuration.

Did you make any changes to the security configuration after the deployment or it acted like that out of the box?


I seem to have found the culprit (it was the hash/password setup process). I was mis-understanding the prompt (newbie user mistake).

I will read through the linked documentation in any case to learn more about the config and security process.