Unable to see prometheus data source index on the dashboard

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):

opensearch 2.12, ubuntu, chrome

Describe the issue:

The indexing on the data store for Prometheus doesn’t seem to work. is there any config that might be missing. I am using helm chart to install the opensearch and dashboard.

Relevant Logs or Screenshots:

Hey @Akshat

Testing this also and kind of have the same issue I think.

I’m running OS/OSD-v2.12.0 on Ubuntu22.0.4

I connected to Prometheus in the Data source section. no issues shown.

Checked my datasource index set…

On the left Pane Observability → Metrics I see this

If I click on any one of those metrics I see this…

Is this Issue you are having also?

@Akshat The provided screenshot shows only index patterns. An index pattern is not the same as an index.

You can list indices by running the following AIP call in the Dev Tools.

GET _cat/indices

The index pattern must be created manually.
Take a look at one of the screenshots provided by @Gsmitt

I used the dev tools and checked the ql-datasources in the list. The issue is that i can see the metrics visualization on the observability->metrics page. when I try to save the visualization and add to the dashboard, it shows me errors like below:

Did you create the data source from the Dashboard UI or with API endpoint? Lets see if this solves the issue Opensearch dashboard goes blank with Json parse error - #6 by Akshat

I did both. Or I should say I tried both. right now I’m just using API.

EDIT: I do have key made, I saw that when I was troubleshooting.

I have the same issue showing up again. I tried 2.11.1 and used default admin admin user and added the master key and it was working. Now when I upgraded 2.12.0 the page goes blank again. I see that there is a new version out yesterday 2.13 and I am going to give this 1 more go. I am getting out of ideas and I hope someone from the community or the contributors look into this soon.

Hey @Akshat

Yeah there is a issue, I posted in Slack and GitHub.

1 Like

Hey @Akshat

I tried version 2.13 same issue

On OpenSearch Slack.com I was just talking to someone about this. I think this maybe fix in version 2.14.

You can see it here…

1 Like

Do any one over there has idea about when this bug was introduced? it would be great to get an invite for the slack channel.

try this

do we have any idea if this will be fixed on 2.14? I was reading the channel and looks like there is going to be a new release soon.

Not sure, you can check GitHub. I think they have a road map.

Check here…