Unable to import Kibana dashboards

Hello everyone,

I’ve tried to import some filebeat dashboards (like the one for mysql module) into Kibana and I am unfortunately out of ideas on how to make this work.

It seems like the API is not working + the Web UI for importing object is also refusing the json format?

I’ve configured the filebeat.yml with the proper credentials but either way I am using, it is either ending up in some error.

Anyone managed to import dashboard into an opendistro cluster running 1.9.0, that is connected to AD and using tenants?

Thank you!


Just to confirm, you’re 100% sure you’re getting data into your indexes? The most common issue I see is folks installing the Elastic licensed version of beats and failing at the license check stage.


Thanks for the reply!

This is using the filebeat-oss version + the web ui / stacks management / saved objects.
Data is flowing into the indexes.

I plan to upgrade to version 1.12.0 next week and see if that brings any kind of improvement.


Great. Also confirm that you’re using the correct version of beats for your version of elasticsearch (1.9 should use 7.8 Elasticsearch).

PS - I wouldn’t upgrade to 1.12 next week - 1.13 should be out about the same time!

1 Like

Hi @searchymcsearchface

I’ve upgrade to 1.13 and it was more or less OK.

BUT, after the upgrade kibana is veeeeeeeery slow.

Anyone else having performance issues with kibana after the upgrade?


I haven’t heard of any other performance problems.

Could you help me understand what you mean by “veeeeeeeery slow” (page load? query? etc.)?


The page is taking between 0.5 and 3 minutes to load on average.
If it cannot load, it usually throws an error like the one below:

Version: 7.10.2
Build: 36136
Error: Setup lifecycle of "opendistroSecurityKibana" plugin wasn't completed in 30sec. Consider disabling the plugin and re-start.
    at https://fancyhost/36136/bundles/core/core.entry.js:6:147917

@valentin That seems super unusual. Everything worked speedily under 1.9.0?

Speedily no, but 2-3x faster than it is loading now and this kind of error never appeared until now.
There was no extra/different data added to the cluster or any other type of changes applied.

OK. Do you mind writing an issue? The security team would probably be the best to help diagnose given the error message GitHub - opendistro-for-elasticsearch/security

I’ve created the following issue on github → https://github.com/opendistro-for-elasticsearch/security/issues/1047


1 Like

Good news,

We’ve managed to track the issue and it was coming from the F5 Load balancer.
http/2 was enabled on the targets and this was causing this long loading times.