changes does not take effect

Hello everyone,

I’ve tried to modify the internal_users.yml file to update the default user’s “admin” password. I’ve generated the new password through and put it into internal_users.yml, but the updates doesn’t take effect when i execute the I’ve tried the following commands:

./ -cd ../securityconfig/ -icl -nhnv \
  -cacert ../../../config/root-ca.pem \
  -cert ../../../config/kirk.pem \
  -key ../../../config/kirk-key.pem


./ -f ../securityconfig/internal_users.yml \
  -t internalusers \
  -icl \
  -nhnv \
  -cacert ../../../config/root-ca.pem \
  -cert ../../../config/kirk.pem \
  -key ../../../config/kirk-key.pem

None of them seems to work. I’ve tried also to restart the two application (Opensearch and Opensearch-Dashboards), but without success. Any idea about what’s going on?

@italosilva Could you share the output of both commands?


I have the old Opendistro installed on the server. When i was executing the, the program was accessing the 9300 port, where this old version was listening. So the modifications i was performing were changing the other program. using -p 9301 option solved my problem.

Thanks, @pablo