Resolved: Security page is not showing right

Hi all,
i have encountered a weird issue with kibana security webpage: it shows up, but there’re no buttons for roles, backends, etc. Only Authentication & Authorization button. When one pushes that button, logout is

tried to google it, no luck so far
plugin status in Kibana status page:
“plugin:opendistro_security@6.6.2 Open Distro Security plugin version 6.6.2 initialised.”
i have kibana version 6.6.2, opendistro-0.8 and default security settings for secirityadmin script
thanks in advance

Hello abisare !
Not sure what happened to you, maybe because you need the multi tenancy mode to make it works?
You don’t have it activated yet.


ok, thanks, ThibaudF.
I’ll try setting it up and post here results

I’ve enabled multitenancy, now Tenants section appeared, with 3 tenants Global, Private and admin_tenant

however, in Security section there’s no changes

i have following in kibana.yml regarding multitenancy

elasticsearch.requestHeadersWhitelist: [“securitytenant”,“Authorization”]
opendistro_security.multitenancy.enabled: true
opendistro_security.multitenancy.tenants.preferred: [“Private”, “Global”]
opendistro_security.readonly_mode.roles: [“kibana_read_only”]

I login as admin, with all_access role. also i have added Global and Private tenants to all_access role in roles.yml
my config.yml with kibana section:

#filtered_alias_mode: warn
multitenancy_enabled: true
server_username: kibanaserver
index: ‘.kibana’
do_not_fail_on_forbidden: false

Hello !
I’m sorry I’m not expert so I will try to give you some help from my experience using Open Distro.
Have you tried changing tenant to admin_tenant? Is the security page different if you change tenants?

My last tip would be to install everything again, you might have corrupted files.

Hope I helped

yes i have tried switching to different tenants, including admin_tenant, but no luck. Reinstalling everything is not an option, because this system is used actively. Anyway, everything else works fine, it is not that critical to have the security UI.

Okay !
Another idea :
Do you have this line enabled in elasticsearch.yml?

opendistro_security.restapi.roles_enabled: ["all_access", "security_rest_api_access"]



No, this option is absent in my config. I’ll check this out and let you know.

that was it! now everything is in place

I think this should be described in the documentation, since it is not obvious.
Thanks for your help, Thi

1 Like

Glad I helped !
Good luck in your journey.

Thi :sunglasses:

1 Like