[repositories plugin] Is it possible to use ACCESS_/SECRET_KEY with GCS?

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):
OpenSearch: 2.10.0, snap distribution
Plugins: repository-s3, repository-gcs
OS: Ubuntu 22.04 and 23.10

Describe the issue:
Currently, the only way I can integrate with GCS for backups is using repository-gcs, which only accepts service-account.
Is there a way to configure repository-gcs to use access/secret-key OR to have repository-s3 instead connected with GCS?
I’ve tried the later multiple times but I am getting the following error at repository creation: Ubuntu Pastebin
I am fairly confident my credentials work, as I can test them with s3cmd.

I’ve tested my deployment against both AWS S3 and Ceph (using microceph snap) and they worked fine.

s3.client.default.endpoint: storage.googleapis.com
s3.client.default.max_retries: 3
s3.client.default.path_style_access: true # also tried keeping it false
s3.client.default.protocol: https
s3.client.default.read_timeout: 50s
s3.client.default.use_throttle_retries: true
s3.client.default.region: us-west2