Remote cluster between es and opensearch

hi, im trying to connect between elasticsearch (7.10.2 and without certs) to opensearch (with configured certs)
is that possible?

When you say connect you mean upgrade or do something along the lines of cross cluster replication?

I meant cross cluster replication
I tried to configure opensearch as the remote but when I try to reindex the error is: empty replay

Hey what version of OpenSearch are you using? I think this may need to be between 7.10.x and 1.3.x.

Also, why are you doing this? Just curious as there might be another way.

hey :slight_smile:
so we are migrating from elastic 7.10.2 to opensearch 2.5.0 and we need to have a remote cluster for our users
about the reindex- the purpose is to move all visualisations from elastic to opensearch so we need to reindex the .kibana index

Ah I see, so unfortunately CCR will not work in that way. It is always setup to go from a lower to higher version so it will likely see that Elasticsearch is 7.10 and will only allow to transfer from OpenSearch to Elasticsearch.

Have you tried a rolling upgrade? This should attempt to preserve your dashboards and data. With this option you could go from 7.10 → 1.3.x → 2.x.x. You would need to do it in that order though as each major release has breaking changes.

1 Like

Maybe take a snapshot to s3 and restore to the opensearch cluster?

1 Like

yes, I tried but it didn’t work

Which didnt work s3 or rolling upgrade? and did it give an error?

Ok if going via s3 didnt work - seems like going through opensearch 1.x is a requirement.
If you are adventurous you can create a single node cluster with opensearch 1.3.
Reindex to it. Then reindex to the opensearch 2.5 cluster.

You can also use something external like Logstash to connect to both clusters and do the reindexing. Here’s a recipe: Recipe: Reindexing Elasticsearch Documents with Logstash - Sematext