Received fatal alert: certificate_unknown

I tried to generate an admin certificate and config it to elasticsearch.yml already. But I always get this error while running Received fatal alert: certificate_unknown

Can anyone help with this? I’m setting up the stack from this article Running Open Distro for Elasticsearch on Kubernetes | AWS Open Source Blog


I just ran into the same thing. My cluster was starting fine a few weeks ago with no errors in the logs.

Came back to stop/start the cluster today and saw the same error in the logs.

If I come across anything I’ll report back.

So it appears, at least for my issue, I had several other instances that were running that weren’t configured correctly for their certs.

I thought I had all of them shut down but one but apparently our server admin group restart one or more of them and they were trying to connect to this server.

thank @sthomps

I gone through this issue by using kirk certifications

I am getting the same issue when I try to run OpenSearch server, @Khoa isn’t the kirk certificates by default in the OS demo configuration?


Could you open a new thread and describe your issue in the details?
Also, would you mind sharing your elasticsearch/OpenSearch config files?

What OS or ODFE version are you running? Is it a new cluster or you were replacing existing certs with new ones.

@pablo yes, I will share the config files. OS version is 1.0.1 and yes its a new cluster configuration where I am simply using demo configuration but I am calling the shell scripts from java code