Perf-top not showing metrics

When I run

perf-top-linux --dashboard dashboards/ClusterOverview.json --logfile ~/perftop.log

I dont see any metrics. in the perftop log , I see

Failed to retrieve data for metrics. HTTP(S) response was:
        {"error":"Metrics Processor is not initialized. The reader has run into an issue or has just started."}

and when I do netstat I see

 netstat -plten |grep 9600
tcp6       0      0 :::9600                 :::*                    LISTEN      9003       24774060   16613/java

Any further steps to triage the issue

Hi gude.ravi,
Do you know if you have enabled https for the reader process. If so, can you try

perf-top-linux --dashboard dashboards/ClusterOverview.json --logfile ~/perftop.log  --endpoint https://localhost:9600

Can you also check if the reader process is running at all. You can run a sample command like the one below and see the response

curl -XGET http://localhost:9600/_opendistro/_performanceanalyzer/metrics?metrics=Latency,CPU_Utilization&agg=avg,max&nodes=all

[if you have https enabled]

curl -k -XGET https://localhost:9600/_opendistro/_performanceanalyzer/metrics?metrics=Latency,CPU_Utilization&agg=avg,max&nodes=all

Hi @sendkb

I am experiencing a similar issue and when I run the curl command i get “curl: (7) couldn’t connect to host”

Any ideas why this might be happening? I would appreciate it

Can you give us some more details if the above commands are not working for you but you are able to get metrics using the sample request here:
API - Open Distro Documentation ?