Opensearch pod failling with CrashLoopBack Error

Hi Team,

We have tried OpenSearch installation using OpenSearch helm chart in the AKS Cluster. We could see pod are getting failed with CrashLoopBackError with the below error.

Warning Failed 21s (x4 over 65s) kubelet Error: failed to create containerd task: OCI runtime create failed: container_linux.go:370: starting container process caused: process_linux.go:459: container init caused: rootfs_linux.go:59: mounting “/var/lib/kubelet/pods/aecd5368-462b-4af5-addb-d904c980c3f4/volume-subpaths/config/opensearch/2” to rootfs at “/run/containerd/io.containerd.runtime.v1.linux/” caused: not a directory: unknown
Warning BackOff 9s (x6 over 64s) kubelet Back-off restarting failed container.

Thanks & Regards,

Moved to the DevOps category. @TheAlgo Any thoughts here?

@opensearch Can you manually unmount the volume and force delete the pods and retry again? From a bird view it looks like a mounting issue.

@TheAlgo -we tried that, Still can see Crash Loopback error only.

Could it be the case that you need to point it to a directory instead we are pointing to .yml

tried , but no luck.

Could you please share the entire log snippet

Hi Team,

Due to security constraints, in Our project few polices got enabled. So we disabled Read only filesystem, escalation privileges etc. Post that able to setup OpenSearch using helm in aks cluster.