OpenSearch installation script doesn't recognize default password

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):

Hello everyone,

I am struggeling with the installation of OpenSearch. I downloaded the zip and unpacked and followed the official installation instructions. But I always get the same error message with the OPENSEARCH_INITIAL_ADMIN_PASSWORD.


Windows 10
Open Search 2.14.0

Relevant Logs or Screenshots:

Command Line Logs:
“OPENSEARCH_HOME: C:\Program Files (x86)\opensearch-2.14.0\opensearch-2.14.0” “OPENSEARCH_PATH_CONF: C:\Program Files (x86)\opensearch-2.14.0\opensearch-2.14.0\config” “Running Security Plugin Install Demo Configuration” “OpenSearch 2.12.0 onwards, the OpenSearch Security Plugin a change that requires an initial password for ‘admin’ user.”“Please define an environment variable ‘OPENSEARCH_INITIAL_ADMIN_PASSWORD’ with a strong password string.” “If a password is not provided, the setup will quit.” “For more details, please visit:” ### OpenSearch Security Demo Installer ### ** Warning: Do not use on production or public reachable systems **

Environment Variable

(I use really use this password)

hi @davidcas,

Have you rebooted your machine after setting the environment variable?

Could you run the below on PowerShell and share the output:


Please mask the value of your strong password.


should look something like this:

hi @Mantas

I restarted my computer. The output looks like this:

@davidcas , do you still see the same error?