Open Distro Kibana setup for Docker root-less


I’m working with opendistro. It’s working perfectly fine with docker. But I need to setup it for docker root-less.

As anyone ever done it ?

I’m facing issues with ulimits.

In the docker compose :

        soft: -1
        hard: -1

And my container can’t start due to OCI rlimits type 8.

I have solve this issue by editing this file : /etc/security/limits.conf

And adding a line : username - memlock

And now it’s starting but not working.

The container should create files on /usr/share/elasticsearch/data/ but it won’t.

I have found a solution.

The mounting point was specified in the service config like this :

    volumes :
      - /srv/docker/es01:/usr/share/elasticsearch/

I had the 755 rights on /srv/docker/es01

To debug the issue I run chmod 777 /srv/docker/es01

But after my docker-compose up my folder was back in 755.

I’m not sure to understand why. I have tried to google it, but I didn’t find anything. Does someone have explications or links to help me understand ?

And I work around my problem and I finally fix it using this configuration :

    volumes :
      - ofde-data1:/usr/share/elasticsearch/

    driver: local
      type: none
      o: bind
      device: /srv/docker/es01

I don’t understand the difference between this 2 configurations and why it solve my problems. Does someone hay any clues why ?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.