Not able to create index pattern using all_access role


I’m trying to create an index pattern on newly set up opensearch in k8s, but once I create it and get back to ‘Discover’ tab, there are no index patterns and opensearch suggest creating new one.


  1. Install opensearch and dashboards in k8s using helm charts;

  2. Install fluent-bit to deliver logs to opensearch;

  3. Login under ‘admin’ user with ‘all_access’ role;

  4. Go to ‘Discover’ on WI and create a new pattern;

  5. Pattern is created (screenshot attached);

  6. Go back to ‘Discover’ and there are no index patterns;

  7. Also if I go to ‘Saved Objects’ I get the following error in the browser console:

    "message": "all shards failed: search_phase_execution_exception: [illegal_argument_exception] Reason: Text fields are not optimised for operations that require per-document field data like aggregations and sorting, so these operations are disabled by default. Please use a keyword field instead. Alternatively, set fielddata=true on [type] in order to load field data by uninverting the inverted index. Note that this can use significant memory."

Additional info: I created clusters previously and deleted them along with the disk volumes, so it should be a clean install, but may be this is somehow connected, because I can’t see other reasons for such behavior.

Opensearch/dashboards version: 2.10.0
Opensearch chart version: 2.15.0
Dashboards chart version: 2.13.0

Am I doing something wrong here or maybe it’s a bug?


@sanych Can you create any index manually?

Could you share the values.yml of the OpenSearch helm chart?