Multitenancy cannot find specific .kibana index


I am trying to set up multi-tenant in my cluster. I am creating a new tenant : “test_tenant”. Then put it in a role tenant pattern.

According to the documentation, security plugin creates separate indices for each tenant :


But i am not able to find my .kibana index for my “test_tenant” with my query GET .kibana*

Is it normal ? How to find my test_tenant .kibana index to be able to modify it and add saved object in this tenant ? Users with this tenant have a blank page.

Thank you,

Have you tried GET /_cat/indices/.kibana*?v

Nothing, just get my .kibana_1, kibana_2 etc for each nodes

health status index uuid pri rep docs.count docs.deleted store.size
green open .kibana_task_manager 5yFdnFzlTXKNbnELXEcdQg 1 1 2 0 27.5kb 13.7kb
green open .kibana_5 8Qk2UNLQQOaUIaQtM5H1RQ 1 1 9736 56 7.6mb 3.8mb
green open .kibana_2 g6_HKnfSRUqxdnXqI9bhVg 1 1 5044 272 3.8mb 1.9mb
green open .kibana_1 V11SeWjYSyOxqeqGHUjPjA 1 1 3178 13 2.3mb 1.1mb
green open .kibana_4 Yv9nYd9lT5yoYnwZOQFlAA 1 1 8699 268 6.3mb 3.1mb
green open .kibana_3 HGj_pVWXRTO–KgnHhvPoQ 1 1 7241 151 4.9mb 2.4mb

I am in open distro 1.9. I will switch to 1.12 next month

Have you had a user log in and use that tenant yet?

To note - I was just doing some testing and see that the index for the tenant was only created once I gave a user permission to the tenant, had the user logout, log back in, and switch to the tenant.

I do not give directly user permission to the tenant, but within a role. Then in the Roles Mapping i put backend roles, then users having this backend role get the rights.

At the end, in Account menu, my user see test_tenant in Tenants list, but he is not able to find the index …

@Julien Did you give necessary permissions via roles to the user to create objects in the test_tenant. Once the permission is granted via
tenant_permissions: allowed_actions:
the index object should be created once the user selects that tenant.
This might help: Kibana Multi-Tenancy - Open Distro Documentation

If permission is already granted, but still not resolved the issue, can you check if you are getting any errors in kibana/es logs?