Logstash for Opensearch 1.1.x?

To docker example given in Logstash - OpenSearch documentation works fine with Opensearch version 1.0.0. Is there a version that works with the latest Opensearch version (1.1.x)?

I get this with the latest Opensearch version (docker opensearchproject/opensearch:latest).

Attempted to resurrect connection to dead OpenSearch instance, but got an error {:url=>“https:// admin:xxxxxx@localhost:9200/”,
:exception=>LogStash::Outputs::OpenSearch::HttpClient::Pool::HostUnreachableError, :message=>“OpenSearch Unreachable: [https://admin:xxxxxx@localhost:9200/][Mant
icore::ResolutionFailure] opensearch: Name or service not known”}

Also, I was confused that the OpenSearch documentation I was referring to was “1.1.x” but the example given is using OpenSearch 1.0.0.


That certainly looks like an unrelated problem. Are you sure 1.1.0 is reachable?

Hi, I took another look and you are right.

I am running OpenSearch off the sample docker compose file here Docker - OpenSearch documentation

To confirm that https://localhost:9200 is reachable, I ran curl -XGET --insecure https://localhost:9200 -u admin:admin so the address is reachable. But that was done from the docker host.

Perhaps it’s a docker thing, but after changing hosts => ["https://localhost:9200"] to use the container name hosts => ["https://opensearch-node1:9200"] , it worked.

1 Like

Sounds like docker networking :slight_smile:

Do be aware that using https://opensearch-node1:9200 will peg you to a single node.