Incompatibility with xpack plugins


I was happy to see that opendistro plugins were released individually, and I tried to replace Searchguard Community with opendistro in our ELK 6.7.1 stack.

But when opendistro is installed, Kibana refuse to start if XPack plugin reporting is installed.
After I disabled reporting plugin, Kibana started, but there is an error with xpack spaces plugin, and Kibana is in red state…

I really would like to use opendistro security instead of Searchguard Community, because I will need to use SAML, but I need XPack plugins too…

Are these incompatible ?

I must precise that I don’t have any problems with Searchguard and xpack plugins, and I thought that the opendistro security was forked from Searchguard.

Thank you.


For those who were interested in a solution, I managed finally to install security plugins (Kibana, Elasticsearch) on ELK 6.7.2 (non OSS).

I had to :

And now I have ELK 6.7.2, with XPack free features (monitoring, spaces…) AND opendistro security.

Update : all is working good with ELK 6.8.0 too :slight_smile:


Hello Adrien,

could you put the exact steps on what you did for this solution?
I am trying to do the same with opendistro kibana.

Appreciate your help



So here are the steps :

I currently run with ELK Basic 6.8.3 without problem.

1 Like

thank you so much for the steps Adrien.

I installed opendistro security plugins on the’s kibana 7.2.0 and made the changes to package.json as you suggested and tried to start. it starts but unable to connect to the elastic search running with opendistro-elasticsearch ver 1.2.0 giving me the below exception with xpack

{“type”:“log”,“@timestamp”:“2019-10-04T16:56:37Z”,“tags”:[“license”,“warning”,“xpack”],“pid”:25466,“message”:“License information from the X-Pack plugin could not be obtained from Elasticsearch for the [data] cluster. [security_exception] Unexpected exception indices:admin/get :: {"path":"/_xpack","statusCode":500,"response":"{\"error\":{\"root_cause\":[{\"type\":\"security_exception\",\"reason\":\"Unexpected exception indices:admin/get\"}],\"type\":\"security_exception\",\"reason\":\"Unexpected exception indices:admin/get\"},\"status\":500}"}”}

Not sure if you had encountered this issue.
Please advise


I guess this is coming from the X-pack.
the actual goal is to get the spaces functionality as well along with opendistro security.

does the x-pack spaces feature works for you with rebuild?

@adrien_yhuel Hi adrien , i tried your way on Elasticsearch and kibana 7.4.0 and i got it to work but only when xpack security is enabled , i want to use open distro security and xpack security user login page and other features as well but there is a problem with “Cannot have additional setting [http.type] in plugin [opendistro_security], already added in plugin [x-pack-security]” and when i disable it it works and i get the open distro security login page
is their a way to use the open_distro security and xpack authentication features and login page ?

thanks in advance