Impossible upgrade Opensearch 1.3.2 to 2.0.0 - index version incompatible

Hello,
I have an Opendistro cluster (ODFE 1.3.0/Elasticsearch OSS v7.3.2) that I’m trying to migrate to OpenSearch.

I managed to migrate directly to OpenSearch 1.3.2
When I switch Opensearch to 2.0.0, I get this error :

java.lang.IllegalStateException: The index [[.kibana_-1903174938_ppp_1/XXukuZTDQOywVuG10R5ouA]] was created with version [6.7.1] but the minimum compatible version is OpenSearch 1.0.0 (or Elasticsearch 7.0.0). It should be re-indexed in OpenSearch 1.x (or Elasticsearch 7.x) before upgrading to 2.0.0.

How am I supposed to handle this ?
Isn’t it automatic ?

Thi

1 Like

Hi @ThibaudF - I think if you’re able to get yourself to 1.3.2, it’s just saying you should make a dev console or api call to reindex that particular index so that it will migrate to 2.0.0. It looks like it’s related to a visualization, so you might end up with a viz missing.

It might be useful to reindex twice, since you can only reindex into a different index name. Reindex once to make it compatible with 2.0, and then reindex it again back into the original index name so that you don’t lose any data that might be referred to there.

I would have thought it would be automatic. I’ll consult around and make sure that this isn’t a bug.

Nate

Thank you for the fast answer.

I have multiple index like that, seems related to tenants no?

For example, /_settings for this index:

".kibana_64374215_p831_832": {
		"settings": {
			"index": {
				"version": {
					"created": "6050499",
					"upgraded": "135248027"
				}
			}
		}
	}

Well, until your answer, we will stay at OpenSearch 1.3.2 for now

By the way, should I pass from ODFE 1.3.0 to 1.13.3 before migrating to OpenSearch ?
Will it help for anything?

I just upgraded from 1.3.1 to 2.0.1 and ran into the same situation. I punted and deleted all of my .kibana indices, but I noticed that I now have an index called .kibana_1, which is pointed to by a .kibana alias. Is there a different name I can reindex my settings into, on my other clusters, that Dashboards will find, or is .kibana an artifact that’s going to be staying around for a while?

Hi @reshippie -

I’ve been on vacation, so I’ve been out for a while. I sent up a flare to see if I could get a developer to comment here, especially since this has been reported in the wild twice now.

A genuine thank you for bringing your issues into the collective wisdom of the community.

Nate

For ODFE to OpenSearch, I have seen the same thing and I’ve created an issue: https://github.com/opensearch-project/documentation-website/issues/473. I actually still believe that OpenSearch does not support migration from legacy < 7.0 to OpenSearch 2.x directly and the documents have not been updated to accurately reflect that information.

And as of right now, OpenSearch 3.x (unreleased) does not support migration migration from ODFE and requires at least a lower OpenSearch version.

The original post implies successful upgrade to 1.3.2 directly from ODFE but not to 2.0.0 directly from ODFE.

But there is a comment from 1.3.1 to 2.0.1. This should be automatically supported @reshipple. You can provide details on the error you were seeing?

.kibana is the system index used by OpenSearch Dashboards to store visualizations, settings, index-patterns that help OpenSearch Dashboards function. OpenSearch Dashboards was given the green light to keep the .kibana around since it’s related to functionality and not branding. We will also keep it around because tenancy is highly depended on the .kibana and would require breaking changes to switch this to a new name.

1 Like

I was seeing the same error as ThibaudF, that the .kibana index was from 6.x and not compatible with Opesearch 2.0.1.
1 thing that I realized is that I tried upgrading Opensearch before upgrading Dashboards. I’m going to try upgrading Dashboards first on my next cluster and see if that migration works. I did confirm that all of my existing clusters have the .kibana alias pointed to indices with "version":{ "created": "136217927"}, so I’m cautiously optimistic about today’s planned upgrade.

1 Like

I successfully upgraded another cluster from 1.3.1 to 2.0.1.
Upgrading Dashboards first didn’t make a difference on getting errors about indices created by old versions of Elasticsearch. I got them on both .kibana_task_manager, which deleted, seemingly without any consequences, and on .kibana_1, which was not the index that .kibana points to.

The settings for .kibana_1 were

        "version": { - 
          "created": "6080399",
          "upgraded": "135247927"
        }

Fortunately I had .kibana_2 and .kibana_3 from ES 7.10.2 and OS 1.3.1 respectively. Opensearch 2.0.1 doesn’t have a problem with those 2 indices.

1 Like

This is great news @reshippie ! Thanks for letting us know!