How to Enable Rag For AWS Opensearch Service

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser): 2.11
running aws opensearch service not the serverless version.
Have tried on both m4.search.large data nodes and master nodes
also have tried this on t3.search.mediums for both data nodes and master nodes with the same result

Describe the issue:
In the opensearch console via aws. I run the following api

PUT /_cluster/settings
{
  "persistent": {"plugins.ml_commons.rag_pipeline_feature_enabled": "true"}
}

but I get a failed payload request and kicked out of the console.

Configuration:

current /_cluster/settings request yields the following plugins section

    "plugins": {
      "ml_commons": {
        "only_run_on_ml_node": "false",
        "model_access_control_enabled": "true",
        "native_memory_threshold": "99"
      },
      "index_state_management": {
        "template_migration": {
          "control": "-1"
        }
      },
 

Relevant Logs or Screenshots:

Hey @epuerta

By chance you see anything in the logs that would pertain to this issue besides

getting kicked out of the console? Does the browser close on you or do you get redirect to somewhere else?