How do I troubleshoot what appears to be an empty index pattern in Discover

Hello, we are just starting to use OpenSearch Dashboard as part of our PeopleSoft upgrade to PeopleTools 8.59.21. I have created my first index pattern. I have tried to look at the data in Discover but there doesn’t seem to be any. There should be 4 years of data and I have set the date range to 8 years but I still get no matching data.

I have validated that the query used for the search index returns data. This query was modeled after the query used in the EP_PC_PROJ_RES_KIB search definition. I also followed the same setup in for my new search definition.

I’m not sure how to troubleshoot this. Any tips would be appreciated.

Hi @Ivy

Could your share the output of the following request in the DevTool:

GET _cat/indices?v

Hi Eugene7,

I doesn’t look like I have access to Dev Tools or it hasn’t been configured.

Could you send an example of your input data? When you create an index pattern, can you see your index name in the list ? I have attached the example below.

Yes. I can see the name of the index pattern in the list and I am able to create the index. I’m sorry, I’m not sure what you mean by input data.

This is another screen shot of the index pattern showing the date related fields.

Sorry for my late reply. Could you also share the screenshot of your Discover page with the same index pattern? Could you please share one document that you ingest to the OpenSearch cluster? You can find an example of the document below. Usually, it’s a JSON object.

@Ivy Do you use the timestamp value in the second step?

Hi Eugene,

Thank you so much for trying to help me get this figured out. I finally tracked it down to the security on the projects. We didn’t have that setup. Once I figured out the fix I was able to access the data.