Getting error while bootstrapping opensearch dashboard

Versions (relevant - OpenSearch/Dashboard/Server OS/Browser):
macOS Ventura 13.0.1

Describe the issue:

I installed the necessary versions of the node and yarn that were in the documentation, however, an error occurred in the execution of the osd bootstrap command
the error explicitly indicates the hint yarn install, however, it is does not resolved issue
I tried to search on the Internet, but I did not find anything useful in them

macOS Ventura 13.0.1
node -v 14.20.1
yarn -v 3.5.0

Relevant Logs or Screenshots:

I think Macs (i think in particular we had this on M1/M2 chips?) have some problems yeah

Open new terminal (not docker shell), inside the folder ‘Opensearch-Dashboards’, configure environment variables for OpenSearch Dashboards:

export SERVER_HOST="localhost"
export OPENSEARCH_HOSTS="http://localhost:9200"

Start the OpenSearch Dashboards development server using the start:docker command:

yarn start:docker

After following the previous instructions, OpenSearch Dashboards should be running on To access the OpenSearch Dashboards web interface, use the URL in your browser instead of localhost:5603/fux. Changing the URL to use instead of localhost can help avoid potential issues.

Let me know if this fixed the issue

Those troubleshoot steps should be eventually merged to docker setup manual(even if they’re formatted a bit differently), I believe the PR for that is ongoing

1 Like

Unfortunately, it does not resolved this issue :pensive:

@zloiadil01 did you successfully install yarn? If so are you still seeing the same error? You can verify that you have yarn installed using the command yarn --version in the project root. Also OSD isnt officially supported on MacOS so using the docker setup guide would be the way to go for MacOS right now.