Formatting mustache for MS-Teams webhook

Was using Opendistro alerting to send alerts to Slack using webhook.
I’m trying to setup the same webhook for MS-Teams, but something fails in the message format i’m trying to send.

Here is an example of what i’m sending to Slack:

{“serial”: “{{key}}”, “platform”: “{{#platform.buckets}}{{key}}{{/platform.buckets}}”, {{#version.buckets}}“version”: “{{key}}”, “count”: “{{doc_count}}”{{/version.buckets}}}

This would create for me a list like that:

{“serial”: “", “platform”: "”, “version”: “3.5.31”, “count”: “8”}
{“serial”: “", “platform”: "”, “version”: “3.5.30”, “count”: “7”}
{“serial”: “", “platform”: ".05", “version”: “3.5.25”, “count”: “6”}
{“serial”: "
", “platform”: ".05”, “version”: “3.5.25”, “count”: “6”}
{“serial”: “*", “platform”: "”, “version”: “3.5.30”, “count”: “5”}

I would very much want to keep this list format also when sending it to Teams, but the message
fails to arrive, something with Teams blocking the message for formatting.

any idea how can i keep this list format and to be able sending it to Teams?

issue solved by myself - i had to escaped the double quotes i had inside the message with backslash
so it will look like this :

{text: “{{#ctx.results}}
{\“serial\”: \“{{key}}\”, \“platform\”: \“{{#platform.buckets}}{{key}}{{/platform.buckets}}\”, {{#version.buckets}}\“version\”: \“{{key}}\”, \“count\”: \“{{doc_count}}\”{{/version.buckets}}}

that way it worked.